[neomutt-users] "mutt -e <command>" does not do as documented

Richard Russon rich at flatcap.org
Mon Jun 5 12:48:18 CEST 2017

Hi Xu,

> The documentation for -e is:
>     Specify a configuration command to be run after processing of
> initialization files.

This happens AFTER mutt has read the config files,
but BEFORE the first folder has been opened.

> mutt -e "push <last-entry>"
> I find that the first entry is selected.

This doesn't actually work
It might look like it worked if there was no new mail
(it would select the last entry)

To do what you wanted, try:

    # On entry to a any folder, select the first entry
    folder-hook . 'push <first-entry>'

> is a bug or documentation failure?

A documentation failure.

I've tried to draw a picture of mutt, its screens and its hooks,
but it's fiendishly complicated.

Rich / FlatCap
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 854 bytes
Desc: not available
URL: <http://mailman.neomutt.org/pipermail/neomutt-users-neomutt.org/attachments/20170605/d3d08f33/attachment.sig>

More information about the neomutt-users mailing list