[neomutt-users] GMail SMTP: no authenticators available?

Baron Fujimoto neomutt.org at monkeybutt.com
Wed Jan 20 17:52:06 CET 2021

On Wed, 20 Jan 2021, Pietro Cerutti wrote:

> On Jan 20 2021, 03:10 UTC, Baron Fujimoto <neomutt.org at monkeybutt.com> wrote:
>> Our org's email is hosted by Gmail. I had been using neomutt (built from 
>> MacPorts) successfully for years. Recently though, I can no longer send 
>> email successfully using GMail's SMTP servers. I get the error, "No 
>> authenticators available". IMAP still works fine. This change occurred 
>> while I had a neomutt session open; it was working one day when I left, but 
>> the next day, no bueno.
>> The following in my muttrc was used successfully util this problem began:
>> set smtp_url = smtp://user@example.org@smtp.gmail.com
>> Where user at example.org is my hosted gmail address.
>> I also tried the following with the same results:
>> set smtp_url = smtp://user@example.org@smtp.gmail.com:587
>> I haven't seen any other traffic about this on the list, so presumably it's 
>> not a general problem.
>> Any suggestions would be appreciated.
> Just checked, this works for me (it's plain gmail, not gsuite or anything 
> else enterprisish):
> set smtp_url = smtps://<my_email>@smtp.gmail.com
> set smtp_authenticators = plain
> I use an app password.

Hmm, I tried smtps as the protocol as well, but same results. I don't have smtp_authenticators set, which I believe means it should use the default of "all available methods, in order from most-secure to least-secure" (and where "plain" is bundled in).

Our GSuite uses SAML SSO for authenication, but I don't know if that precludes the use of an app password. I wasn't using an app password before it stopped working however.

More information about the neomutt-users mailing list