[neomutt-devel] Time to kill Buffy
rich at flatcap.org
Fri Aug 3 13:46:26 CEST 2018
Historically, developers have given temporary things funny names: foo, bar, baz.
That's fine whilst development is going on, but when they leak into live
code it becomes a problem.
Much as I love the work of Joss Whedon, naming objects after Vampire
Slayers is a bit odd. It was probably funny twenty years ago; now it's
a bit embarrassing.
`struct Buffy` is a mailbox, so it will become `struct Mailbox`
I'm currently trying to insert an Account object into the hierarchy to
allow account-specific config. This will require some rearrangement so
that we have:
Account -> Mailboxes -> Emails
Incoming -> Mailboxes
Context -> Emails
Rich / FlatCap
-------------- next part --------------
A non-text attachment was scrubbed...
Size: 833 bytes
Desc: not available
More information about the neomutt-devel